// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)(<h(?:3|4|5).*?<\/h(?:3|4|5)>)((.*?\n)*?)(<p>.*?<\/p>)").unwrap();
let string = "<h2>header 2</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок без нака вопроса</h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок со знаком вопроса? </h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}