package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(<h(?:3|4|5).*?<\/h(?:3|4|5)>)((.*?\n)*?)(<p>.*?<\/p>)`)
var str = `<h2>header 2</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок без нака вопроса</h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>
<h3>Заголовок со знаком вопроса? </h3>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aenean tristique semper massa eu rutrum. Pellentesque iaculis lacus eget purus commodo</p>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}