package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\"Petrov\", \"id\":(\d+)\}`)
var str = `{"Ivanov", "id":7},
{"Sidorov", "id":4},
{"Petrov", "id":3},
{"Petrov", "id":2},
{"Kozlov", "id":9};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}