re = /\{\"Petrov\", \"id\":(\d+)\}/m
str = '{"Ivanov", "id":7},
{"Sidorov", "id":4},
{"Petrov", "id":3},
{"Petrov", "id":2},
{"Kozlov", "id":9};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end