const regex = new RegExp('\\{\\"Petrov\\", \\"id\\":(\\d+)\\}', 'gm')
const str = `{"Ivanov", "id":7},
{"Sidorov", "id":4},
{"Petrov", "id":3},
{"Petrov", "id":2},
{"Kozlov", "id":9};`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}