// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\{\"Petrov\", \"id\":(\d+)\}"#).unwrap();
let string = "{\"Ivanov\", \"id\":7},
{\"Sidorov\", \"id\":4},
{\"Petrov\", \"id\":3},
{\"Petrov\", \"id\":2},
{\"Kozlov\", \"id\":9};";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}