import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\\"Petrov\\\", \\\"id\\\":(\\d+)\\}";
final String string = "{\"Ivanov\", \"id\":7},\n"
+ "{\"Sidorov\", \"id\":4},\n"
+ "{\"Petrov\", \"id\":3},\n"
+ "{\"Petrov\", \"id\":2},\n"
+ "{\"Kozlov\", \"id\":9};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}