using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:soy|almond)\s?milk\b|\b(milk)\b";
string input = @"""...almondmilk..."" = no match
""...almond milk..."" = no match
""...almond word(s) milk..."" => matched ['milk']
""...almondword(s)milk..."" => matched ['milk']
""...soymilk..."" = no match
""...soy milk..."" = no match
""...soy word(s) milk..."" => matched ['milk']
""...soyword(s)milk..."" => matched ['milk']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring, ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}