re = /\b(?:soy|almond)\s?milk\b|\b(milk)\b/m
str = '"...almondmilk..." = no match
"...almond milk..." = no match
"...almond word(s) milk..." => matched [\'milk\']
"...almondword(s)milk..." => matched [\'milk\']
"...soymilk..." = no match
"...soy milk..." = no match
"...soy word(s) milk..." => matched [\'milk\']
"...soyword(s)milk..." => matched [\'milk\']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring, '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end