package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:soy|almond)\s?milk\b|\b(milk)\b`)
var str = `"...almondmilk..." = no match
"...almond milk..." = no match
"...almond word(s) milk..." => matched ['milk']
"...almondword(s)milk..." => matched ['milk']
"...soymilk..." = no match
"...soy milk..." = no match
"...soy word(s) milk..." => matched ['milk']
"...soyword(s)milk..." => matched ['milk']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring, `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}