// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:soy|almond)\s?milk\b|\b(milk)\b").unwrap();
let string = "\"...almondmilk...\" = no match
\"...almond milk...\" = no match
\"...almond word(s) milk...\" => matched ['milk']
\"...almondword(s)milk...\" => matched ['milk']
\"...soymilk...\" = no match
\"...soy milk...\" = no match
\"...soy word(s) milk...\" => matched ['milk']
\"...soyword(s)milk...\" => matched ['milk']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring, ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}