use strict;
my $str = '"...almondmilk..." = no match
"...almond milk..." = no match
"...almond word(s) milk..." => matched [\'milk\']
"...almondword(s)milk..." => matched [\'milk\']
"...soymilk..." = no match
"...soy milk..." = no match
"...soy word(s) milk..." => matched [\'milk\']
"...soyword(s)milk..." => matched [\'milk\']
is combined with creamy soy and milk. a fruity and refreshing sip of spring,
is combined with creamy milk. a fruity and refreshing sip of spring, ';
my $regex = qr/\b(?:soy|almond)\s?milk\b|\b(milk)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}