using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\[)(www\.)?\w*[.][a-z]{2,5}(?!\])";
string input = @"Der Text soll verdeutlichen, wie der reguläre Ausdruck für www.google.de funktioniert, aber auch für google.de muss es klappen. Aber auch für (www.google.de). Sowie für http://www.google.de. Auch für [google.de falaffel]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}