import re
regex = re.compile(r"(?<!\[)(www\.)?\w*[.][a-z]{2,5}(?!\])", flags=re.MULTILINE)
test_str = "Der Text soll verdeutlichen, wie der reguläre Ausdruck für www.google.de funktioniert, aber auch für google.de muss es klappen. Aber auch für (www.google.de). Sowie für http://www.google.de. Auch für [google.de falaffel]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")