#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)"
Local $sString = "paragrafo6o" & @CRLF & _
"par123" & @CRLF & _
"par 89" & @CRLF & _
"par.21" & @CRLF & _
"pars.344" & @CRLF & _
"exempar234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")