using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)";
string input = @"paragrafo6o
par123
par 89
par.21
pars.344
exempar234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}