// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)").unwrap();
let string = "paragrafo6o
par123
par 89
par.21
pars.344
exempar234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}