const regex = /(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\W|^)(paragrafo(?:s?)|par[s.]?\\.?)\\s*(\\d+)', 'gm')
const str = `paragrafo6o
par123
par 89
par.21
pars.344
exempar234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}