package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\W|^)(paragrafo(?:s?)|par[s.]?\.?)\s*(\d+)`)
var str = `paragrafo6o
par123
par 89
par.21
pars.344
exempar234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}