#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:https?:\/\/)?(?:www\.)?\w{2,7}\.com(?!\/team|\/forum)\S*" & @CRLF & _
""
Local $sString = "https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/" & @CRLF & _
"https://www2.website.com" & @CRLF & _
"http://www2.website.com/" & @CRLF & _
"https://www.website.com/" & @CRLF & _
"http://www.website.com/" & @CRLF & _
"https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search" & @CRLF & _
"https://www2.website.com/team/" & @CRLF & _
"https://www2.website.com/team" & @CRLF & _
"https://www2.website.com/forum/index.php" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")