import re
regex = re.compile((r"\b(?:https?:\/\/)?(?:www\.)?\w{2,7}\.com(?!\/team|\/forum)\S*\n"), flags=re.MULTILINE)
test_str = ("https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/\n"
"https://www2.website.com\n"
"http://www2.website.com/\n"
"https://www.website.com/\n"
"http://www.website.com/\n"
"https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search\n"
"https://www2.website.com/team/\n"
"https://www2.website.com/team\n"
"https://www2.website.com/forum/index.php\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")