import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:https?:\\/\\/)?(?:www\\.)?\\w{2,7}\\.com(?!\\/team|\\/forum)\\S*\n";
final String string = "https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/\n"
+ "https://www2.website.com\n"
+ "http://www2.website.com/\n"
+ "https://www.website.com/\n"
+ "http://www.website.com/\n"
+ "https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search\n"
+ "https://www2.website.com/team/\n"
+ "https://www2.website.com/team\n"
+ "https://www2.website.com/forum/index.php\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}