const regex = /\b(?:https?:\/\/)?(?:www\.)?\w{2,7}\.com(?!\/team|\/forum)\S*
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:https?:\\\/\\\/)?(?:www\\.)?\\w{2,7}\\.com(?!\\\/team|\\\/forum)\\S*
', 'gm')
const str = `https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}