re = /\b(?:https?:\/\/)?(?:www\.)?\w{2,7}\.com(?!\/team|\/forum)\S*
/m
str = 'https://www2.website.com/forum/index.php?threads/redimensionner-une-image.8314/
https://www2.website.com
http://www2.website.com/
https://www.website.com/
http://www.website.com/
https://www2.website.com/engine/search?name=&description=&file=&uploader=&category=2145&sub_category=all&do=search
https://www2.website.com/team/
https://www2.website.com/team
https://www2.website.com/forum/index.php
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end