const regex = /^ --start
(1?[\-\.\_]?) question mark makes the block or single character before it optional
([0-9]{3})
(-?)
([0-9]{4})
$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ --start
(1?[\\-\\.\\_]?) question mark makes the block or single character before it optional
([0-9]{3})
(-?)
([0-9]{4})
$', '')
const str = `
1.
555.
555-
1212
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}