$re = '/^ --start
(1?[\-\.\_]?) question mark makes the block or single character before it optional
([0-9]{3})
(-?)
([0-9]{4})
$/';
$str = '
1.
555.
555-
1212
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);