# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^ --start\n"
r"(1?[\-\.\_]?) question mark makes the block or single character before it optional\n"
r"([0-9]{3})\n"
r"(-?)\n"
r"([0-9]{4})\n"
r"$")
test_str = ("\n"
"1.\n"
"555.\n"
"555-\n"
"1212\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.