package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[_\s])(SK|PL|TESTCAT|FOO)(?:[\s_.]|$)`)
var str = `TESTCAT sdksdks
sadkjsdj_SK.txt
sadkjsdj_SK
SK_PL_.php
PL_sdjkdsjk_FOO.txt
filename w whitespace SK.php`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}