// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|[_\s])(SK|PL|TESTCAT|FOO)(?:[\s_.]|$)").unwrap();
let string = "TESTCAT sdksdks
sadkjsdj_SK.txt
sadkjsdj_SK
SK_PL_.php
PL_sdjkdsjk_FOO.txt
filename w whitespace SK.php";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}