re = /(?:^|[_\s])(SK|PL|TESTCAT|FOO)(?:[\s_.]|$)/
str = 'TESTCAT sdksdks
sadkjsdj_SK.txt
sadkjsdj_SK
SK_PL_.php
PL_sdjkdsjk_FOO.txt
filename w whitespace SK.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end