import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[_\\s])(SK|PL|TESTCAT|FOO)(?:[\\s_.]|$)";
final String string = "TESTCAT sdksdks\n"
+ "sadkjsdj_SK.txt\n"
+ "sadkjsdj_SK\n"
+ "SK_PL_.php\n"
+ "PL_sdjkdsjk_FOO.txt\n"
+ "filename w whitespace SK.php";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}