const regex = /(?:^|[_\s])(SK|PL|TESTCAT|FOO)(?:[\s_.]|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[_\\s])(SK|PL|TESTCAT|FOO)(?:[\\s_.]|$)', 'g')
const str = `TESTCAT sdksdks
sadkjsdj_SK.txt
sadkjsdj_SK
SK_PL_.php
PL_sdjkdsjk_FOO.txt
filename w whitespace SK.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}