#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([1-9][0-9]{5})\b"
Local $sString = "1 :- ho no 55 A Akbarpur Behrampur vijay nagar 7827183008 Ghaziabad UP 201009" & @CRLF & _
"2 :- 47- A 57798/4343 ward no 7 ghaziabad 201009 UP " & @CRLF & _
"3 :- 45456/343 ward 76587 Lucknow 110087" & @CRLF & _
"4 :- ho no 55 a behrampur ghaziabad 210 501"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")