re = /\b([1-9][0-9]{5})\b/m
str = '1 :- ho no 55 A Akbarpur Behrampur vijay nagar 7827183008 Ghaziabad UP 201009
2 :- 47- A 57798/4343 ward no 7 ghaziabad 201009 UP
3 :- 45456/343 ward 76587 Lucknow 110087
4 :- ho no 55 a behrampur ghaziabad 210 501'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end