import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([1-9][0-9]{5})\\b";
final String string = "1 :- ho no 55 A Akbarpur Behrampur vijay nagar 7827183008 Ghaziabad UP 201009\n"
+ "2 :- 47- A 57798/4343 ward no 7 ghaziabad 201009 UP \n"
+ "3 :- 45456/343 ward 76587 Lucknow 110087\n"
+ "4 :- ho no 55 a behrampur ghaziabad 210 501";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}