const regex = /\b([1-9][0-9]{5})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([1-9][0-9]{5})\\b', 'gm')
const str = `1 :- ho no 55 A Akbarpur Behrampur vijay nagar 7827183008 Ghaziabad UP 201009
2 :- 47- A 57798/4343 ward no 7 ghaziabad 201009 UP
3 :- 45456/343 ward 76587 Lucknow 110087
4 :- ho no 55 a behrampur ghaziabad 210 501`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}