#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\s()]+(?:\([^()]*\))?$"
Local $sString = "I-IVWM_Ask-21_(max_2h)" & @CRLF & _
"" & @CRLF & _
"D-7849_DG303_(max_4h)" & @CRLF & _
"" & @CRLF & _
"Aliante_Privato"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")