$re = '/^[^\s()]+(?:\([^()]*\))?$/m';
$str = 'I-IVWM_Ask-21_(max_2h)
D-7849_DG303_(max_4h)
Aliante_Privato';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);