// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\s()]+(?:\([^()]*\))?$").unwrap();
let string = "I-IVWM_Ask-21_(max_2h)
D-7849_DG303_(max_4h)
Aliante_Privato";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}