package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s()]+(?:\([^()]*\))?$`)
var str = `I-IVWM_Ask-21_(max_2h)
D-7849_DG303_(max_4h)
Aliante_Privato`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}