# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(BARCODE).*\n.*\n.*\n.*//gm;t' <<< "this is a line
this is a line
this is a line BARCODE
this is a line1
this is a line2
this is a line3
this is a linethis is a line
this is a line"