$re = '/.*(BARCODE).*\n.*\n.*\n.*/m';
$str = 'this is a line
this is a line
this is a line BARCODE
this is a line1
this is a line2
this is a line3
this is a linethis is a line
this is a line';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;