import Foundation
let pattern = #".*(BARCODE).*\n.*\n.*\n.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is a line
this is a line
this is a line BARCODE
this is a line1
this is a line2
this is a line3
this is a linethis is a line
this is a line
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)