// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*(BARCODE).*\n.*\n.*\n.*").unwrap();
let string = "this is a line
this is a line
this is a line BARCODE
this is a line1
this is a line2
this is a line3
this is a linethis is a line
this is a line";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}