# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\|\|\K(\d+)(?=\|\|[\s\S]+#\1(\d+))|(?:\r?\n#.*)+$/$1$2/g;t' <<< "||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0011||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0122||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
||0232||
#001112
#012234
#023213"