import re
regex = re.compile(r"\|\|\K(\d+)(?=\|\|[\s\S]+#\1(\d+))|(?:\r?\n#.*)+$")
test_str = ("||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0011||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0122||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"||0232||\n"
"#001112\n"
"#012234\n"
"#023213")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)