#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^<!--(?!\[[^]+])(?:(?!-->).)*-->$"
Local $sString = "<!-- some comments 1 -->" & @CRLF & _
"<!-- 1.91 -->" & @CRLF & _
"<!--" & @CRLF & _
"//-->" & @CRLF & _
"<!-- -->" & @CRLF & _
"" & @CRLF & _
"<!--[if IE]> <![endif]-->" & @CRLF & _
"<!--[if !IE]><!--> <!--<![endif]-->" & @CRLF & _
"<!--[if IE 6]> <![endif]-->" & @CRLF & _
"" & @CRLF & _
"<!--[if lte IE 6]><html class="ie6 no-js">" & @CRLF & _
"<!--[if gt IE 8]><!--><html class="no-js"><!--<![endif]-->" & @CRLF & _
"<!--[if IE]>" & @CRLF & _
"<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">" & @CRLF & _
"<![endif]-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")