use strict;
my $str = '<!-- some comments 1 -->
<!-- 1.91 -->
<!--
//-->
<!-- -->
<!--[if IE]> <![endif]-->
<!--[if !IE]><!--> <!--<![endif]-->
<!--[if IE 6]> <![endif]-->
<!--[if lte IE 6]><html class="ie6 no-js">
<!--[if gt IE 8]><!--><html class="no-js"><!--<![endif]-->
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<![endif]-->';
my $regex = qr/^<!--(?!\[[^]+])(?:(?!-->).)*-->$/smp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}