using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<!--(?!\[[^]+])(?:(?!-->).)*-->$";
string input = @"<!-- some comments 1 -->
<!-- 1.91 -->
<!--
//-->
<!-- -->
<!--[if IE]> <![endif]-->
<!--[if !IE]><!--> <!--<![endif]-->
<!--[if IE 6]> <![endif]-->
<!--[if lte IE 6]><html class=""ie6 no-js"">
<!--[if gt IE 8]><!--><html class=""no-js""><!--<![endif]-->
<!--[if IE]>
<meta http-equiv=""X-UA-Compatible"" content=""IE=edge,chrome=1"">
<![endif]-->";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}