import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<!--(?!\\[[^]+])(?:(?!-->).)*-->$";
final String string = "<!-- some comments 1 -->\n"
+ "<!-- 1.91 -->\n"
+ "<!--\n"
+ "//-->\n"
+ "<!-- -->\n\n"
+ "<!--[if IE]> <![endif]-->\n"
+ "<!--[if !IE]><!--> <!--<![endif]-->\n"
+ "<!--[if IE 6]> <![endif]-->\n\n"
+ "<!--[if lte IE 6]><html class=\"ie6 no-js\">\n"
+ "<!--[if gt IE 8]><!--><html class=\"no-js\"><!--<![endif]-->\n"
+ "<!--[if IE]>\n"
+ "<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge,chrome=1\">\n"
+ "<![endif]-->";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}